WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers

主机环境:CentOS6.5

PHP5.6.1

在编译安装PHP时,提示告警信息:“configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.”

提示re2c版本较低


这里它提示的是告警而非错误,但是为了验证它是否是致命的,所以必须了解re2c的作用

re2c的介绍:http://re2c.org/

re2c的下载:http://sourceforge.net/projects/re2c/files/re2c/

经确认,re2c可以提高性能,那就开始升级吧

方法1:(源代码安装)

下载最新的re2c版本,下载地址http://sourceforge.net/projects/re2c/files/re2c/0.13.7.5/re2c-0.13.7.5.tar.gz/download

# tar xf re2c-0.13.7.5.tar.gz

# cd re2c-0.13.7.5

# ./configure

#make && make install

再次编译安装,发现告警信息消失


方法2:yum安装

首先必须启用epel源

#yum -y install re2c

如果生产线上经常部署,你就把这个插件写入php环境检查吧

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页